`
444878909
  • 浏览: 637423 次
文章分类
社区版块
存档分类
最新评论

hdu1171Big Event in HDU

 
阅读更多

Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others)Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19403Accepted Submission(s): 6785


Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.

Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.

Sample Input
2 10 1 20 1 3 10 1 20 2 30 1 -1

Sample Output
20 10 40 40

Author
lcy

Statistic|Submit|Discuss|Note

这道题是很明显的背包问题;

有两种方法,一种是转化为01背包来解决。

一种是利用01背包和完全背包结合来解决。

相对而言,01背包更容易实现。

但是利用01背包和完全背包就会更加有效,时间复杂度更小。

下面有两种方法介绍。

一:01背包

/* 01背包 1500ms*/
#include<stdio.h>
#include<math.h>
#include<string.h>
int w[5009];
int dp[125010];
int N,V,M;
int main()
{
    int i,j,s,n;
    int value;
    while(scanf("%d",&N)&&N>=0)
    {
        value = 0;
        j = 1;
        for(i=0;i<N;i++)
        {
            scanf("%d%d",&V,&M);
            value+=V*M;
            for(s=0;s<M;s++)
                w[j++] = V;
        }
        n = j-1;
        int aaa = value;
        value = value/2;

        memset(dp,0,sizeof(dp));
        for(i=1;i<=n;i++)
            for(j=value;j>=0;j--)
            {
                if(j-w[i]>=0)
                {
                    if(dp[j-w[i]]+w[i]>dp[j])
                        dp[j] = dp[j-w[i]]+w[i];
                }
            }
  
                printf("%d %d\n",aaa-dp[value],dp[value]);


    }
    return 0;


}

二:多维背包


/*多维背包 98ms*/
#include<stdio.h>
#include<math.h>
#include<string.h>
int v[59];
int w[59];
int dp[155010];
int N,value;
int max(int a,int b)
{
	return a>b?a:b;
}
void wan(int vv)//完全背包
{
	for(int i=vv;i<=value;i++)
		dp[i] = max(dp[i],dp[i-vv]+vv);
}
void zone(int vv)//01背包
{
	for(int i=value;i>=vv;i--)
		dp[i] = max(dp[i],dp[i-vv]+vv);
}
int main()
{
	int i,j;
	while(scanf("%d",&N)&&N>=0)
	{
		if(N==0){printf("0 0\n");continue;}
		value = 0;
		j = 1;
		for(i=1;i<=N;i++)
		{
			scanf("%d%d",&v[i],&w[i]);
			value+=v[i]*w[i];
		}
		int aaaa = value;
			value = value/2;
			
			memset(dp,0,sizeof(dp));
			for(i=1;i<=N;i++)
			{
				if(v[i]*w[i]>=value)
				{
					wan(v[i]);
					continue;
				}
				int BB = 1,B = w[i];
				while(BB<B)
				{
					zone(v[i]*BB);
					B-=BB;
					BB = BB*2;
					
				}
					zone(B*v[i]);
				
			}
				printf("%d %d\n",aaaa-dp[value],dp[value]);
		
	}
	return 0;
		
}


还有一种就是巧用二进制思想,不用完全背包

/* 187ms */
#include<stdio.h>
#include<math.h>
#include<string.h>
int w[5009];
int dp[125010];
int N,V,M;
int main()
{
    int i,j,n;
    int value;
    while(scanf("%d",&N)&&N>=0)
    {
        value = 0;
        j = 1;
        for(i=0;i<N;i++)
        {
            scanf("%d%d",&V,&M);
            value+=V*M;
            /*for(s=0;s<M;s++)
                w[j++] = V;*/
            int B = 0,BB = 1;
            while(B<=M)
            {
                w[j++] = V*BB;
                B+=BB;
                BB = BB*2;
                
            }
            if(B>M)
                w[j-1] = (M-(B-BB/2))*V;
        }
        n = j-1;
		int aaa = value;  //特别要注意这个要保存
        value = value/2;	//不能在下面要用到时再用value*2
							//因为value刚开始时是奇数时就会丢失数据
        memset(dp,0,sizeof(dp));
        for(i=1;i<=n;i++)
            for(j=value;j>=0;j--)
            {
                if(j-w[i]>=0)
                {
                    if(abs(dp[j-w[i]]+w[i]-j)<abs(dp[j]-j))
                        dp[j] = dp[j-w[i]]+w[i];
                }
            }
            if(dp[value]>(aaa-dp[value]))
                printf("%d %d\n",dp[value],aaa-dp[value]);
            else
                printf("%d %d\n",aaa-dp[value],dp[value]);


    }
    return 0;


}




分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics